Resolved
Lobby #1 is now back online and fully accessible to players.
Identified
Our team is making a quick update to our #1 lobby server. It will be briefly offline but will be back up shortly. You can still join the network, but you'll be temporarily redirected to Lobby #2.