Complete
The maintenance period is now complete!
To learn more about this release, please check our updates channel on Discord.
In progress
This maintenance period is still ongoing, but we are nearing completion. We are very eager to release this to all of you. See you in the next update!
In progress
This maintenance period is now underway!
Scheduled
We will be conducting scheduled maintenance on January 19th, starting at 10:00 AM CST. During this time, the Minecraft server will be unavailable, and we expect the maintenance period to last approximately nine hours. If the maintenance period needs to be extended, we will update this page and notify you in our status channel via our Discord server.
This maintenance will allow our team to begin work on an exciting new feature: External Maps. We are thrilled to bring this to you and will provide more information as we approach the release date in our updates channel via our Discord server. Thank you for your understanding and support!