Complete
This maintenance period is now concluded.
Please watch the announcements and updates channel for more information.
In progress
Time for an update! We’re continuing work to bring the servers back online and out of maintenance mode. A detailed update will be posted in the #updates channel soon, including a few previews to help everyone understand why this maintenance period has taken a bit longer to complete.
For now, we’ll remain in maintenance mode, and we’re hopeful we’ll be able to open the doors by the end of this weekend. Thank you for your continued patience and understanding!
In progress
It’s finally Friday, and we’re much closer to the finish line than when we started this maintenance period. You might see some previews or even a soft opening later tonight — no promises just yet, but we’re hopeful.
There’s still a bit more work to do, and we know you’re eager to jump back in. Thanks for bearing with us!
In progress
Back at it again this morning!
Today’s plan is to finish the remaining connections, put together some informational aids, and build AI-based Minecraft characters that behave like NPCs. Wait… NPCs, right? Yeah, those make more sense.
In progress
We’re getting closer and closer to reopening the servers, folks!
Just a few more things to tackle — mostly small fixes at this point.
In progress
World migrations are complete, and plugin data is now up to bat ⚾
In progress
Who knew transferring worlds could be this exciting? Next up: plugin data!
See you in the next update, folks!
In progress
We’re back at it again this morning, folks. As always, updates will be posted throughout the day.
Per our recent announcement, we’re very excited to reopen soon.
In progress
Another day of maintenance is behind us, but there’s still more work to do. We’re getting closer to reopening and are on track to start back up first thing tomorrow morning. The light at the end of the tunnel is definitely in sight! See you all then.
In progress
Is it just me, or do I see Endermen? Huh, when did they get their hands on the server?!
Anyway, we’re almost there, folks.
In progress
We’re back at it this morning, working behind the scenes to wrap up this maintenance as soon as possible. Updates will be posted here on the status page and in our Discord server.
In progress
We’ve made great progress during today’s maintenance, but there’s still more behind-the-scenes tinkering to do. The TrilogyMC network will stay offline for now while we keep things in the workshop.
Our team will jump back in tomorrow at 9:00 AM CST, and we’ll post our next update by 10:00 AM CST (and more if anything big changes before then).
This maintenance is powering some major infrastructure and network upgrades to help TrilogyMC run smoother, faster, and more reliably. Thanks for hanging in there with us — we can’t wait to show you what we’ve been building.
In progress
We’re still hard at work behind the scenes and aiming to have everything back up as soon as possible. In the meantime, grab a cup of coffee, read a book, touch some grass (or snow if you’re up in the northeastern US), or throw on a movie. Sit tight and relax — we’ll be back soon!
In progress
*grabs another coffee, does a dramatic stretch* Yep, we’re still here, tinkering away behind the scenes!
In progress
This maintenance period is now underway. Updates will be posted on this page and shared via our Discord server.
Scheduled
We will be conducting scheduled server maintenance on Monday, the 23rd of February, starting at 6:00 AM CST.
During this time, the TrilogyMC network and all player-facing services will be unavailable. While we expect the work to be completed within several hours, the maintenance window may extend longer if needed.
If additional time is required, we will update this page and post an announcement in our status channel on Discord.
This maintenance will allow our team to perform infrastructure and network improvements needed to support normal activity across the network.
Thank you for your understanding and continued support.