Resolved
We’ve received confirmation that it’s safe to bring the servers back online. Thank you for your patience and understanding during this brief maintenance period.
Identified
Our upstream provider is investigating a recurring issue and needs to take the server offline for a short time. We’re sorry for the repeat downtime and will post further updates here.
Identified
We are investigating an unplanned server restart that occurred at 19:55 UTC during an approved maintenance window to fix an underlying issue. The Trilogy Minecraft Server is currently down while we work with our upstream provider to restore service. We will post updates on this incident here and apologize for any inconvenience this may cause.