Complete
This maintenance period is now concluded.
Thank you for your continued patience and understanding.
In progress
This maintenance is still in progress. Any updates will be posted here and on our Discord server.
In progress
This maintenance window will begin in approximately 1 hour and 54 minutes. As mentioned in the first update, this work is being performed by our upstream provider. We do not anticipate any downtime; however, if any occurs, rest assured that all services will be restored as quickly as possible.
Scheduled
Our upstream provider will perform maintenance on both our LAX and ASH nodes from 12:00 AM CST on March 28th through March 30th, within the same timeframe. We do not anticipate server downtime during this period, but if it occurs, we will notify users via this page and our network-status channel on Discord. We apologize for any inconvenience caused, but this scheduled maintenance is essential for applying updates and improvements to our network infrastructure.